Saturday, October 19, 2013

Upgrade Error - The database collation cannot be changed if a schema-bound object depends on it.

Hi all,

Found a issue while upgrading from Navision 5 SP1 to NAV 2013 related to database collation.

Posted the issue on mibuso and got the hint to resolve same.

I thought I should share it with you all, so here it is.

Issue -

1. Completed Step 1 Successfully.

2. Tried to Open the database in NAV 2013, and get below listed error during database conversion.


CAUSE OF ERROR -

1. This error occurs when we try to upgrade a database which does not have local language pack of Microsoft Dynamics NAV.

RESOLUTION -

1. Take Navision backup of database on old version (in my case NAV 5 SP1).

2. Create new database with collation that is requested by error message in old version.

3. Perform upgrade steps as suggested by standard Microsoft Upgrade manual.

I hope this will help some of the readers.

Regards,
Saurav Dhyani
www.sauravdhyani.com

No comments:

Post a Comment

Popular Posts